Band steering with Sonos

Hi everyone

I’m using the TG589vac v2 (17.2) provided by Cuckoo.
I have a stereo pair of Sonos speakers (Sonos One and Sonos One SL), and I’ve noticed the following:

  • One of the speakers connects to 2.4GHz, the other to 5GHz (which is weird, as I thought Sonos didn’t support 5GHz at all)
  • One of the speakers occasionally stops working while playing music, while the other one keeps working fine. After about 15, seconds, the dead speakers comes back to life.

I spoke to Sonos about this and they advised to disable Band Steering which I tried to do, and noticed that now I have 2 separate wifi networks (2.4GHz and 5GHz). Not sure if this is ideal as I wouldn’t know which one to pick for all my other devices.
They also advised to disable Airtime Fairness and to enable UPnP - I couldn’t find these two and honestly I don’t know what they are.

Has anyone experienced anything similar with Sonos?
Thank you!

@acecco01

Not ideal I know but I’ve had similar issues with sonos rollouts in the past. I do not A couple of ideas:

  1. You are correct in thinking Sonos typically do not connect to 5GHz networks; this may have been enabled in a recent firmware update. I would typically set up the 2.4GHz with a different name to differentiate from the main 5GHz network. For example if your wifi was called WACKYRACERS; call the second network WACKYRACERS-LEGACY. This is done by changing the SSID name in the Wireless → Access Point section.

  2. Band Steering can be disabled from Wireless → Access Point; toggle the switch to the off position.

  3. Airtime Fairness is not a feature provided in the router.

  4. UPnP is found under WAN services.

2 Likes

Thanks for the feedback @Kalimero

@acecco01 Do let us know if this gets sorted? Thinking about getting speakers myself sometime soon…

1 Like

@Alex Sonos speakers are great in that you set them up and forget about them. Sonos did fork their system so that the older hardware run on the Sonos S1 app; and the newer hardware on the S2 app. So long as you ensure they are running on 2.4Ghz they are sweet :slight_smile:

Thank you both!
@Alex the speakers are great, I’m not an expert but I do like the sound quality, considering I have a small flat and don’t really have the space for amplifiers and professional equipment.
@Kalimero I decided to keep Band Steering enabled as I don’t like having 2 separate wifi networks for 2.4 and 5. I noticed sometimes, after rebooting the router, both speakers connect on 2.4. I have now moved the router a bit further towards the room (currently it lives on the TV unit, with my Apple TV and a cordless phone, so I know it’s not ideal).

This is what Sonos customer service recommend.

Just as an FYI - if you are going to set channels rather than leave on auto; make sure to pick one that is not congested with any nearby Wifi networks (neighbours etc…)

3 Likes