Port Forwarding for Plex

Hi all,

I’m running a Plex server but am encountering the “Remote Access disabled” message, despite Remote Access being enabled in the settings. Most of the advice I’ve seen suggests setting up port forwarding internally with specifically assigned ports so that Plex doesn’t have to be dynamic.

Has anyone else come across this issue previously? And how would I do Port Forwarding on the Technicolor router as it’s not obvious to me. All the tutorials I’ve seen work great if you have a Linksys / Netgear etc but not the Technicolor one and the format is different when I access the router.

Thanks in advance for any ideas that are suggested.

Hiya @Tranceking (Pete) & Welcome To The Cuckoo Community !!! :smiley: :egg:

Where are you seeing the “Remote Access Disabled” message is it from the router menus or from within the Plex Server program itself.

I suspect it will be a Port Forwarding Issue that you will have to set up if you know what the port numbers are that you need.

Let me know which model of the Technicolor Router you have been sent as there’s a few out in the wild at present and I’ll see if I can help guide you the correct way.

Normal router users should have UPNP enabled and what this does is it opens the ports as the Programs your using needs them at the time.

Port Forwarding just sets up a rule that permanently opens the selected port range eg…0001 - 1000 for example and redirects it to an internal ip address and hardware on the router.

It sounds more complicated to do than it actually is.

1 Like

Hi Phantom,

The Remote Access Disabled is from inside the Plex Server software, not the router menu.

The router I’ve been sent is the DGA0122. I have found the Port Forward section but don’t quite understand the setting up process within the router settings is all.

The various Plex tutorials all recommend ensuring that port 32400 is made available, however some recommend a different external port to internal port. Either way it’d would be handy to better understand the router settings as these seem to be slightly different to what I’ve dealt with previously.

It’s frustrating as it did all work initially but as the server has grown in complexity this part has decided to fall over. Clearly it’s a common issue though as Plex devote a page of their Help guides towards trying to fix it. Internally I’m absolutely fine and can stream to the TV or my Fire Tablet with no problems when I’m on the WiFi but as soon as I’m away from the network it doesn’t want to know.

Hiya @Tranceking

Sorry for the delay in getting back to you

Can you provide a screenshot of this by any chance as I don’t use Plex Server myself so this way it just helps if I can roughly see what your seeing also which platform are you running it on as I only have access to the xbox 360 version and windows.

Also I suspect it means you can’t access your Plex Server externally eg…on a train or on a work break via mobile data or other WiFi hotspots and that’s a different issue altogether but port forwarding would still need to be setup if UPNP Isn’t active.

This router is similar to the original router that Cuckoo send out by way of the software on it but with minor changes so let me see if I can grab you some screenshots from that and guide you through it (later today).

If you have any links to these support articles then it will save me searching them out (but I’m the type of person that will anyways :laughing: )

Most routers are fairly generic in the way they setup there options they just rename there sections to technical words that non technical users can understand what they mean so you do have to hunt around to find what your looking for once you’ve found the appropriate section then it’s plain sailing and your on your way to making things run.

This sounds like the secondary issue I mentioned above where inside your 192.168.1.x private domain apart from port forwarding being set up things will work fine however…here comes the BUT…

When your outside of your private network you cant connect back to home this is simply because you don’t have access to your DYNAMIC IP address which is your real address to connect to your router back home over the internet.

Now this can be solved 1 of 2 ways you can purchase a Static IP at a small charge onto your Cuckoo Plan which gives you a fixed number to access your router at anytime eg… 1.2.3.4 (much like a phone number) by raising a support ticket on email from your account email address with the team on hello@cuckoo.co OR by ringing in

"OR*

using an external domain company that give you a type of web address such as tranceking.yourdomain.com <-not currently real

and this does the same thing as the static IP address mentioned above but gives you a unique web address to HOST* your Plex Server on your router there are places that offer this for free and some charge a fee but this allows your web address to always connect to your router despite what your external dynamic address is when your router drops and randomly restarts giving you a new external address to confuse you.

I had many head scratching moments with this in the beginning as I used to do remote computer maintenance for friends so this is all self taught knowledge + support guides and many different programs to get my head round so i can imagine what your thinking just by reading my words.

I think I’ve covered most of this but a Cuckoo team member has also recently mentioned Plex Server recently as a project he was thinking about so I’m going to pull him in to this conversation just because I leave him out of things so much…come ere @afenton90 see what you’ve done lmao :laughing:

1 Like

Haha :smile: I appreciate it.
I was already snooping on this thread to see if I could help out. I think you’ve hit the nail on the head though with the static IP option. To me that sounds like the underlying cause of it stopping working.

2 Likes

Hi @Tranceking,

I’ve used plex for years, one thing you don’t need is a static ip as long as you are logged into your plex account on your server then when you login through the various plex apps it should be visible, I’m assuming you are running this on a windows machine?

Dan

2 Likes

he’s aliiiiiivvvvveeeee @dan where have you been hiding.

@afenton90 at least I included you this time around…but seriously it’s something I haven’t looked at but feel it’s something to actually look at as there name is getting about slot at the moment.

1 Like

I have ermcough been locked out of my discourse account till Tommy helped me get back in.

2 Likes

Hahahah oh @dan what am I going to do with you and you call yourself the Head Of Tech !!! @Tommy is the Head Of Gremlins and probably caused it in the first place.

I’m just glad to see your back.

1 Like

Wow! So many replies!! Thanks all for jumping on.

@PhantomR1982 Here’s the Plex guidance on Remote Access issues;

https://support.plex.tv/articles/200931138-troubleshooting-remote-access/

I don’t need to purchase a Static IP as all the software needs is for the machine the Plex server is hosted on to be given a static IP by the router and then the Port Forwarding takes care of the rest. Yes @dan this is being run on a Windows machine.

I love Plex. This particular server is fairly new as I’m on a new build and it originally worked for the remote access however I’ve made changes to the server over the last few weeks and I’ve just discovered the remote access has stopped functrioning properly.

Anyways as a reasonably experienced Plex serverer (I’ve even paid for the Plex Pass I love it that much) it’d be good to contribute to any other conversations that are going on.

1 Like

Just to add - I’ve actually been a Plex user for the last 7 years. I haven’t found anything which comes close to this for when you’re wanting a good interface for viewing all of your media in one space.

1 Like

Hi Again @Tranceking :smiley:

I know how to engage the team,so I’m glad to see they are interested in this as well as myself…there’s not many ISP’s…hold on is there actually any out there that would engage with there users respectfully like this eh @alex ← the boss man.

Yeah that’s the second link on my bookmarks and I did start to look over it earlier & then real world things took over and I got badly distracted today however I haven’t forgotten about this so thanks for linking it here.

The IP address from the internal network 192.168.x.x is fine but is only fixed when it is binded to a specific device MAC Address to access your Plex Server Internally however externally is where the Static/Dynamic IP address comes in or the domain option…while @dan did say you don’t need a static IP on this and @afenton90 kinda says you do I’m taking everyone’s points on board and not discounting any of them and that’s where it can get confusing…I’m not perfect but I like a challenge when it’s thrown at me…I’m going to personally look into the Plex Server on windows tomorrow and re-go over this threads posts as well

Static IP’s are more of an external connection method that is fixed for things like CCTV Cameras/Internet Web Servers etc…it can simplify things but that’s where the Static IP Addresses & Domain Options can be handy and more cost effective however if it gets to this stage over that of a Dynamic Address that changes randomly and can cause headaches.

I’ve heard about Plex through random support articles and seeing it in my Xbox apps as mentioned above but initially thought it was just a way of making your own “On Demand” Service like the premium companies have so this didn’t intrigue me at this point…until now where I’m seeing more questions about the software and thats what’s peaking my attention. :thinking:

That’s what this Community is setup for so that users with experience in things that others don’t have experience in can point others in the right direction and to create new friendships possibly at the same time and to just keep the conversations and community alive so dive in anywhere you see fit and in time you may even be able to teach me about using Plex without even realising it. :stuck_out_tongue_winking_eye:

Don’t you meant Functioning ??? (Tip:- Use the pencil at the bottom of a post to edit and you may get a treat when you hit save edit)

Server + User added together to create a new word Serverer not bad & I’ll be honest now as I read this as Severer as in Chopping a head off at first…whoops.

7 years gives you more than enough experience than probably many other users and probably as a result you’ve seen features come and go much like a beta/trial system for a company as updates and patches are released overtime so own that experience.

1 Like

Emby is okay, I’ve found it to be slightly more performant and does basically the same thing. Plex lost a little loyalty from me when they made it harder to find your own media and started to push their own stuff.

Re: not needing a static IP; when you login to Plex on your server / computer it relays your current IP back to Plex, therefore when you login on your devices outside your home it uses that IP that was relayed to Plex

1 Like

Never heard of it,alas I guess there’s lots out there like this in the wild that I haven’t experienced that you have.

Hmmm so maybe it is just the port forwarding issue on the router then where the ports need to be opened outside of the UPNP that turns it on as needed,It sounds like the relay is working a bit Iike a DDNS service then from outside access to the network…jump on at any point as the thread expands if you have the screens in front of you before I do as every little helps @dan (providing you don’t break your account again :laughing: )

I used to do a lot of Torrent hunting/seeding back when it was really popular before most places on the P2P bandwagon got shut down with a program called Azureus it was so complex to setup but really did well on a upto 56k connection pre Broadband Technology…but Azureus started to do the same thing where they pushed there own files and content which I then walked away from.

1 Like

Evening folks!

Thanks again for all the replies. Good to see this has stirred a conversation about about a service I suspect not that many know about.

I have a few things I’d like to add as I think there are some updates to report;

  1. functrioning - Definitely a typo. In my defence it was around 3am and I was a little fuzzy at that point. I’m also getting used to a (very) cheap keyboard that came with the machine I ended up getting after separating from my wife last year.

  2. serverer - not a typo :smiley: But was meant as Server and User :wink:

  3. Over 7yrs I’ve seen various different functionalities come and go. Like many I do have a wish-list of things the service doesn’t have that would make it a lot easier to use, however it’s not a big company and so they need to prioritise platform UX over improved usability for more experienced users who wish to migrate a server across builds or want a “reset to last best configuration”.

  4. @dan may I ask which issues you’ve had about finding your own media? Personally I’ve found it’s all to do with selecting the right option for media type and then not expecting any metadata from the usual sources. If you preload your files with enough metadata then Plex finds it easier to configure your media.

  5. @PhantomR1982 the Static IP thing is what I was getting at with not needing one at the ISP-end. Giving a device a static address from within the router and then port-forwarding allows external Plex connections to go through the fixed port into the server as the log-in provides the connection to the server. Plex does clever bits behind the scenes to ensure it’s connecting to the correct IP.

  6. I’m pinning down the source of what’s triggering the remote access to disconnect. If I reset Remote Access and use my phone via 4G then I connect and access media without any issue. Whereas - my ex and kids live across town and their main TV is connected to my Plex server as it logs into my account. The TV seems to trigger the disabling of the remote access service somehow. It requested to have the account logged in last night and allowed them access for a few hours before disconnecting again. I’ve asked them to access via their Xbox which has the Plex app and is logged in, so I want to see if the Xbox triggers the same issue, and if not then it’s their TV causing the disconnection.

Plex has recently started their own media service where they provide TV and films (albeit not recent blockbusters) however this is ad-supported. It’s not a bad choice of media but then again it’s not a brilliant choice of media. That said it is free so would be a good start for those who get a free account and can’t afford Prime or Netflix.

And call me sad but I also love that I can get the software to play a trailer from one of the films on the server and also a little pre-roll (sorry I’m from the 80s VCR days lol) which adds to the enjoyment for me :smile:

I’m exposing Jellyfin externally (similar to Plex but open source) - and it’s working totally fine. I do however have a static IP from Cuckoo. All I needed to do was port forward from the router.

1 Like

In Plex, you’ll need to enable this setting, otherwise your plex server will refuse to serve requests externally:

image

I would also recommend maybe fronting your Plex server with Nginx or similar. It’s good practice!

1 Like

Hi @kn100 many thanks for the suggestion. The issue I’ve had with Plex is that despite enabling remote access, Plex would still fail to provide a connection to external devices that had permission to access the server. So I turned this function on and it would briefly go green to suggest that devices outside of my network could access the server and after a few seconds would turn red to inform me that no devices could access remotely.

The really weird thing in all of this is that my phone, if I switched to 4G and thus become a device outside the network, could access media. Yet other devices couldn’t.

Well, thank you everybody for all of your comments on this thread. It’s been really interesting to read all the different input that people have contributed with this.

I have fixed the problem myself through patience and graft lol

So the solution was simple. What I’ve done is built a new server on a new pc I was building as a pet project. I finally got everything hooked up and then Win10 installed, and once everything was updated I installed and built a new Plex server. I have Remote Access enabled and since the build was completed the only server downtime has been from restarts to the main PC after Windows updates. Remote Access is still on from it’s initial installation a few days ago.

I have absolutely no idea why the old server had the issues it did. Either I’ve installed a plug-in it didn’t like or support, or there was a conflict from some other piece of software (which is unlikely as I’ve previously found Plex to be a very stable platform, but I can’t rule it out). So I’m planning to completely wipe the old PC, put a fresh Win10 on and the PC will be going to the kids for them to do schoolwork on.

Just as a p.s.

I’d be very interested to contribute where possible on other threads relating to Plex, for where people on here have queries. I’m not always on these boards as I have other places I inhabit, so if anything crops up about Plex and someone wants to tag me into them I’d love to join in.