Router bridge mode - Unifi network slow speed

My internet connection is working through my Unifi Dream Machine… but at only 20% of the speed I got when it was just the Cuckoo router. (10mps through the Unifi Dream Machine, 50mbps when just connected to the Cuckoo router)

I followed these steps to get to where I am now.

I’ve read about DHCP, IPv6 and making sure the IP addresses aren’t the same on my Cuckoo router and Unifi router, but am a bit lost as to what I actually need to do.

What other settings do I need to change (on Cuckoo router or the Unifi network) to make it work full speed through Unifi?

Thanks in advance for any help anyone has!

@wacjames10 Are you achieving these speeds via wired or wifi on the unifi? If wifi; can you plug an ethernet cable between your computer/laptop and the unifi unit and run a speedtest (i use fast.com as an example)

Also - You havent got IDS / IDP / Threat Management turned on the unifi unit correct?

Hi @Kalimero
Thanks for your reply.
I got these speeds yesterday from fast.com connected with ethernet cables.
I have the medium level of threat prevention turned on in unifi network settings.

@wacjames10 Turn off threat prevention and retry. Threat prevention will lower the throughput (speed) of the unifi unit; by how much i am unsure but i recall on a unifi usg pro it went from 1gbps down to 250mbps when ips (threat prevention) was enabled.

@Kalimero thanks, just gave that a go but hasn’t made any difference unfortunately.

@wacjames10 ok lets do some basic checks:

  1. cuckoo router is in bridge mode (you can check this on the unifi as the Internet(WAN) port should have a public IP address rather than say something resembling 192.168.x.x)

  2. do you have any vlans set up? if so; any of these running a reduced thoroughput policy (think of a guest policy where you allocate/restrict total bandwidth to 20%)

  3. do you have QoS set up?

  4. Are you running the latest stable firmware release for the unifi unit?

(2) and (3) may not make any sense; if they do not dont worry as they would not be enabled by default and this is good in this case.

@Kalimero
re.1 - yeah think so, begins with a 79. ?
re.2 - no vlans set up (i just have the LAN for my dream machine)
re.3 - don’t know what this is
re.4 - yes dream machine looks like it has the latest, but there is a network update available

@wacjames10 yup its in bridge mode. so thats right.

Seems to be a simple setup; i’m struggling to think of what else. Have you got smart queues enabled?

@Kalimero
re.3 - i just checked, i have “enable smart queues” enabled

@wacjames10 What have you set your smart queues to? Turn this off and run fast.com and you will be pleasantly suprised.

@Kalimero
yup, turned it off and it sped up. They were set to 12000kbit/s. Thank you.
Is there any point having it turned on and setting the limit higher?

Yesterday, I also clicked “auto-configure” on the fields “Gateway/IP subnet” and “DHCP range” on the LAN settings page. Do I need to somehow change this back?

@wacjames10 You need to set that to approximately 10% of your topline speed if you are wanting to use smart queues / QoS. I assume you are not a new customer or are in the process of having your line undergo a relearn (as its during this 10 day period that the speed may fluctuate)

The better way is to speak to cuckoo support and ask to see what your line speed is; failing that make sure you only have one device plugged into the unifi unit and wifi is turned off (to ensure no other devices are connected) and then run a speedtest. Whatever speed you get here take 10% off and then put that in your smart queues; remember there are values for both downstream (download) and upstream (upload).

As an example; if fast.com gave you 70mbps down and 10mbps up; in smart queues you would put in:

Download: 63mbps (63000kbit/s)
Upstream: 9mbps (9000kbit/s)

I would only enable smart queues / qos if you have congestion on your network; if you dont have this issue or need to prioritise traffic then i would leave it off.

Re: auto-configure; it just sounds like you have let the unifi itself set the internal LAN ip range but i could be mistaken - im not staring at my gateway at the moment but if you could take a screenshot i’d be better placed to answer :slight_smile:

@Kalimero
re. smart queues - got it, makes sense.
I am a new cuckoo customer, connected yesterday
Screenshot of LAN settings here…

@wacjames10 Ahh the LAN setup is fine; you can leave that as-is. However leave smart queues turned off until the 10 day period is up; and then re-run the steps i outlined. You need to give it 10 days however as the line hasn’t settled yet.

@Kalimero
Great, thanks for your help :grinning:
Am interested to understand what all the settings/fields mean. Do you know a good source to read up on the fundamentals?
Cheers

@wacjames10 Yip - the Ubiquiti website has a wiki of sorts; accessible via help.ui.com however certain parts of the wiki will tend to not keep up with the constant changes of the UI platform so things sometimes get out of date; but its a start :slight_smile:

@Kalimero super, thanks again for your help :slight_smile: