Technicolor DWA0120 DLNA server

Hello!

I’m new to the flock, I went live on Friday.

Everything has gone very smoothly and I am very happy. The only thing I need help with is not urgent and just a nice-to-have if I can get it working.

I am very impressed by the DWA0120 router provided by Cuckoo. It’s the first ISP-issue router I’ve had that has decent file sharing/media sharing capabilities.

I have a spare USB hard drive knocking around so I plugged it in to the USB port on the router and I was impressed to see it automatically create the Samba shares and I am able to connect to that from any computer in the house and copy files to/from it.

My TV wanted to get in on the action too and it started advertising a DLNA server I could connect to and pull videos, photos or music from. I have some experience with DLNA servers but unfortunately it doesn’t seem to work as I was expecting.

You can see from the manual here that the DLNA server is supposed to be able to serve media found on the USB connected hard drive to DLNA compatible clients like my LG WebOS TV.

From page 62 of the manual:

The DLNA server lists all audio, video and picture files located on the connected USB storage device.

I have formatted the USB storage device as a single NTFS partition and uploaded a sample MP4 video to it (30MB).

But whenever I go to Content Share > Technicolor DLNA > Photo & Video > Movies > All Movies I’m met with a screen that says:

No photo, video files or folders exist in storage device.

I did wonder whether it might be related to the TV itself, but I have also used other DLNA clients such as the one built in to VLC Player and, again, although it finds the DLNA server advertised by the router, it cannot see any media that has been added.

I have asked Cuckoo support and they are unsure why it wouldn’t work (but are trying to find the answer) . In the meantime, has anyone else used their Cuckoo Technicolor DWA0120 router as a DLNA server successfully?

Many thanks!

2 Likes

Out of curiosity do images show up on the DLNA server?

Edit: Do you have any other formats to test? mp4 without 256 encoding an avi or something else?

2 Likes

Thanks for the quick reply @dan. Unfortunately they do not. That’s the same on the TV app and on VLC player (if anyone knows any other UPnP/DLNA clients that are worth trying I’m happy to do so).

The only thing I haven’t tried so far is music but…

…no alas that doesn’t work either.

2 Likes

@chrisd try formatting a drive as FAT32(crazy I know) and try that

2 Likes

Sorry missed this. I’ll try some more formats first and let you know.

Will try this too and report back.

2 Likes

Definitely try other formats first, if I had a spare DWA here I would try too. VLC should be good enough to decode anything from a DLNA service.

2 Likes

Welcome @chrisd to the Flock & The Cuckoo Community :egg: :smiley:

Oii @dan thats my line “out of curiosity” :stuck_out_tongue:

You mentioned that you formatted the USB Storage Drive that is inserted
to the Technicolor Routers USB port as NTFS now as this is more of a Windows
File system im guessing it might be because the router cant see the NTFS File system
and its probably looking for a FAT32 Based system so try formatting it like this first and
pop the files on that partition to see if that makes any difference.

USB Thumb Sticks are notorious for only working on FAT32 with slight modifications compared to windows natively using NTFS These days.

1 Like

No go on that. Tried a simple AVI and non-H264 encoded MP4.

Next I’ll try reformatting with FAT32 and I’ll try another drive entirely if I can (just have to find it…). It’s a large drive hence why I’m currently using NTFS. Though I may be able to partition it into smaller parts for testing.

Thanks @PhantomR1982!

The manual is pretty clear that NTFS should be supported and in terms of the Samba server I can copy files to/from it without issue but I guess it’s possible the DLNA part specifically might struggle.

I shall report back!

Thanks for the replies so far :slightly_smiling_face:

2 Likes

Yeah the manual does state NTFS should work, but it could be a fat lie :joy:

4 Likes

@chrisd

Since when do Human beings read and believe manuals these days lol.

FAT Based File systems are to be honest still more reliable than NTFS in
my eyes most TV’s with PVR/DVR Functions including my own will format
a storage device with a type of FAT file system and also a common mistake
by techs are that hardware will see the full size of a drive automatically there
could be a file size limitation that they can only read up to for ex…160gb.

Its all down to the routers hardware/firmware support.

@dan Really thats just a bad joke

2 Likes

@PhantomR1982 it was more a painful laugh than anything else

3 Likes

Sadly using FAT32 so far hasn’t made any difference.

I still need to find a different USB storage device just to rule that out. Will report back when I remember which safe place I stored it in…

2 Likes

I really, really enjoyed that.

2 Likes

Oh you would find it comical @tommy :yum::sunglasses:

1 Like

Ok.

  1. I’ve tried different formats
  2. I’ve tried a different file system (FAT32 versus NTFS)
  3. I’ve tried a different USB storage device (just a USB stick formatted with FAT32)
  4. I’ve tried different UPnP/DLNA clients
  5. I’ve tried rebooting the router

No change, unfortunately.

From my past experience with other UPnP servers like Serviio and similar things like Plex, usually there’s a mechanism to force a refresh of the media library. I’m not sure by what mechanism the media library would update on the router but I presume rebooting the router or connecting different drives would trigger something.

So I’m a bit stuck now.

Is there anything to check in terms of the router firmware? Is there any advice available from Technicolor themselves via Cuckoo (their support pages say support only available via service providers).

Thanks for everyone’s input so far :slightly_smiling_face:

1 Like

@chrisd Its always the safe place that you end up forgetting where it is
so it so safe you cant find it when you need it.

1 Like

@chrisd

How were you formatting the USB Device ??? Through the intended device or
through the Desktop PC/Laptop.

I was wondering about Plex as an option as its pre-installed into my console
yet i’ve not used it.

Have you looked through the web interface on the router at 192.168.1.x (where x could be 1 through to 254) and login with the details on the base of the router just to see if the USB Port
is enabled as most routers even have UPnP disabled by default.

It could be something simple as a disabled tick option on the router.

If you can supply screenshots from the router interface it will allow us to see what your seeing.

1 Like

Formatted through Windows 10.

USB is definitely enabled and being seen by the router. I have Samba file sharing enabled so I can write files to/from the USB storage over the network.

UPnP and the DLNA features are enabled (and are by default). If they were disabled I’d not be able to see the router as a media server in the VLC Player or TV content sharing app.

A screenshot to verify:

2 Likes

Try formatting through a TV as thats where i was going wrong
as tv software doesnt take into account new O/S Practices.

Is there anything in that “show advanced” section at the top
right of the interface that might be hidden.

FAT32 is pretty ancient so if that’s not going to work I’m not sure what will.

An interesting development (thanks for the idea) is that if I connect the USB storage to the TV directly via its USB port - it doesn’t provide the facility to format the drive unfortunately - but it does see the disk and its contents and it can play them.

So this is definitely seeming to point more towards the router itself.

The advanced options are for changing the Samba/DLNA names so it just makes these fields editable (everything else remains unchanged, and no other options are displayed):

Thanks all for ideas/advice so far.

1 Like